IonCube Loader is a software tool, that's necessary to run files that are encoded with ionCube PHP Encoder. The latter is an application designed to make PHP code human unreadable, so as to protect it from reverse engineering and / or not authorized usage. A lot of script-driven apps, especially forums, cms and e-commerce solutions are encrypted with ionCube PHP Encoder, therefore when you purchase a script and you find that ionCube is on the list of hosting environment prerequisites, you have to make sure that your web hosting server has the instrument pre-installed. Though it's not that hard to install it if you have your own server, it is close to impossible to do that on a shared web hosting server because the PHP environment shall have to be precompiled and all clients on the server will be affected.

IonCube in Shared Hosting

When you buy a shared hosting through us, it'll be created on our in-house made cloud platform where ionCube Loader is already present, so you won't have any problems to manage any script application which requires the instrument in order to run appropriately. In addition, we supply several different releases of PHP, which means that if you switch the version, you'll have to enable ionCube once again. Our system remembers the adjustments you make, and when you move back to the earlier release of PHP which was active for your account, ionCube Loader will already be enabled. Both the PHP version as well as the ionCube tool can be managed through the PHP Configuration area of our Hepsia website hosting Control Panel. Any adjustment that you do takes literally just a click and it takes effect right away.

IonCube in Semi-dedicated Servers

As all semi-dedicated server accounts are created on our advanced cluster platform and ionCube Loader is available on it, you will be able to use any script application which requires the tool in order to work properly. With several clicks in your Hepsia web hosting Control Panel you're able to activate or deactivate ionCube for the PHP version that's currently active for your account. Because we support multiple releases of PHP simultaneously, you'll need to do this each time you switch to a different release, but if you revert back to a release that you have already used, our system will remember your preference and ionCube Loader will already be activated. If you have a couple of sites in the same account and they require different releases of PHP, you are able to set up a php.ini file in each domain folder and with several lines of program code you'll be able to define both the PHP version plus the status of ionCube no matter what is selected for the hosting account altogether.